Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

Manual Gearbox XYZ Sensor Failures
Post Reply  Down to end
Page 7 of 7 <1234567
dippo
 


Member Since: 14 Oct 2016
Location: kent
Posts: 3

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Bonatti GreyDiscovery 3

Hi
I am new to world of Discovery 3 and bought one in good faith in March this year it is a 2005 model 120k serviced and looked good to me...I had cam belt done straight away and just put it through MOT which it failed on an Orange P which came up day before MOT booked....was told to get new EGR valves....£600.. decided against that and followed someone on here to re-calibrate the manual gear box which worked!!!
Problem I think came from gearbox being a bit sloppy, you have to fight to find gears and naturally the gearstick if in neutral would NOT ping back to sit in between 3-4 as you would expect. My question is how do I fix it? I read a few other threads and the detent circlip was mentioned....will this help? Is this the equivalent of the D2 BIAS PLATE? Wi;; it give my gearbox it's spring back?
  
Post #171986214th Oct 2016 3:11 pm
View user's profile Send private message View poster's gallery Reply with quote
The Keeper
 


Member Since: 22 Apr 2016
Location: Cheshire
Posts: 27

United Kingdom 2009 Discovery 4 TDV6 GS Manual Stornoway GreyDiscovery 4

Had all of the sysmtems on my MY59 Discovery 4 2.7 TDV6 last week and followed the instructions from Stevie B in this thread...

1) Find a long straight and quiet section of road.Neutral
2) Select LOW Ratio.Shocked
3) Reverse for about 200 yards or until you get the beep and the R on the dash gear number indicator. And then a tiny bit more for good luck. Stop, then...Neutral
4) Go forwards in 1st until number appears. Clutch pedal must be fully raised each time.Exclamation
5) Then up through the Gears waiting for each of the numbers to appear. Do not skip any gears!Mad
6) Stop at 6th, back into neutral, switch off engine.Confused
7) After a brief rest, I took a couple of minutes just to make sure all the bad ju ju was gone and to have a quick wee as it was just all too exciting.Whistle
Cool Restart and select High Ratio and you're on your way..Laughing

All now sorted Very Happy Respect Stevie Bow down
 D4 - Stornoway Grey
2.7 TDV6 - Manual
EGR Blanked
BAS Remap
Rear privicy glass
Discovery Sport steering wheel
20" Landmark Wheels
Black Landmark side vents
Black rear lights
Black side indicators 
 
Post #172113517th Oct 2016 8:03 pm
View user's profile Send private message View poster's gallery Reply with quote
dippo
 


Member Since: 14 Oct 2016
Location: kent
Posts: 3

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Bonatti GreyDiscovery 3

Hey Stevie

Yeah I had seen this neat trick on here and already done it....it works however the light has come back 3 times now in last week...I think it is the wobbly gearstick? it does not snap back into position as you would expect.

Thanks

Darren
  
Post #172136018th Oct 2016 9:46 am
View user's profile Send private message View poster's gallery Reply with quote
hgrimmett
 


Member Since: 11 Oct 2009
Location: Bledlow Ridge, Bucks
Posts: 683

2007 Discovery 3 TDV6 XS Manual Buckingham BlueDiscovery 3

The wobbly stick is to do with a broken detent circlip. That's a 10 minute job and 50p part... I doubt that's your problem to be honest.
 -------------------------------------------------------------------

D3 '07 (56) XS TDV6 Buckingham Blue
BAS Remap, EGR emulators & FBHIC
New EVERYTHING... 
 
Post #172139618th Oct 2016 11:19 am
View user's profile Send private message View poster's gallery Reply with quote
dippo
 


Member Since: 14 Oct 2016
Location: kent
Posts: 3

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Bonatti GreyDiscovery 3

I actually bought a clip last week...due to the size of it i thought maybe i had bought wrong thing...have you a link to any video or instructions on how to fix?
Also do you think this is reason for calibration falling out?

Many thanks!
  
Post #172139818th Oct 2016 11:21 am
View user's profile Send private message View poster's gallery Reply with quote
hgrimmett
 


Member Since: 11 Oct 2009
Location: Bledlow Ridge, Bucks
Posts: 683

2007 Discovery 3 TDV6 XS Manual Buckingham BlueDiscovery 3

http://www.disco3.co.uk/gallery/albums/use...0guide.pdf Thumbs Up

No I don't think it would be a reason for the calibration failing but I don't really know and until you do the detent you'll not know...
 -------------------------------------------------------------------

D3 '07 (56) XS TDV6 Buckingham Blue
BAS Remap, EGR emulators & FBHIC
New EVERYTHING... 
 
Post #172450925th Oct 2016 9:00 pm
View user's profile Send private message View poster's gallery Reply with quote
bronjen
 


Member Since: 31 Mar 2015
Location: Derby de2
Posts: 59

United Kingdom 2005 Discovery 3 TDV6 Base 5 Seat Manual Buckingham BlueDiscovery 3
X Y sensor issue

A while back my xy sensor started playing up,
I have recalibrated numerous times successfully only for it to stop working a few days later, however the gear indicator does work in all gears.
Have changed the clutch that was worn
have replaced the gear lever circlip that was worn
The sensor does work as the gear lever comes out of reverse for a second,
When in neutral on a slope if I let the D3 roll backwards R is indicated and reverse sensor and reverse lights work.
I was advised to clean the magnet, I have trawled the web and can't find any reference or pics to help me with my task.
Over the christmas break I have access to a four poster ramp, so my plan was to drop the rear of the box, remove the 4 screws that hold the sensor and remove the magnet and clean up the area before replacing the unit.
Has any one done this and how far do i have to drop the rear of the box, while am in that area is there anything else i should check
Advice as always warmly welcomed
thanks
Ron Cool
  
Post #175498429th Dec 2016 10:00 am
View user's profile Send private message View poster's gallery Reply with quote
The Keeper
 


Member Since: 22 Apr 2016
Location: Cheshire
Posts: 27

United Kingdom 2009 Discovery 4 TDV6 GS Manual Stornoway GreyDiscovery 4

Have you tried this Bronjen?

1) Find a long straight and quiet section of road.Neutral
2) Select LOW Ratio.Shocked
3) Reverse for about 200 yards or until you get the beep and the R on the dash gear number indicator. And then a tiny bit more for good luck. Stop, then...Neutral
4) Go forwards in 1st until number appears. Clutch pedal must be fully raised each time.Exclamation
5) Then up through the Gears waiting for each of the numbers to appear. Do not skip any gears!Mad
6) Stop at 6th, back into neutral, switch off engine.Confused
7) After a brief rest, I took a couple of minutes just to make sure all the bad ju ju was gone and to have a quick wee as it was just all too exciting.Whistle
Cool Restart and select High Ratio and you're on your way.

I also re-calibrated the XY sensor several times with my IID tool and the fault returned each time. Did the above and the problem was resolved and hasn't reoccurred.
 D4 - Stornoway Grey
2.7 TDV6 - Manual
EGR Blanked
BAS Remap
Rear privicy glass
Discovery Sport steering wheel
20" Landmark Wheels
Black Landmark side vents
Black rear lights
Black side indicators 
 
Post #175503029th Dec 2016 11:41 am
View user's profile Send private message View poster's gallery Reply with quote
bronjen
 


Member Since: 31 Mar 2015
Location: Derby de2
Posts: 59

United Kingdom 2005 Discovery 3 TDV6 Base 5 Seat Manual Buckingham BlueDiscovery 3
X Y sensor issue

Hi sorry I should have said in my post I have carried out the gear relearn procedure numerous times including switching off until the car goes to sleep (red light on dash goes off) it last for a couple of hours or days, then we lose reverse / sensors but interestingly not the gear numbers on the dash

R Confused
  
Post #175505329th Dec 2016 12:07 pm
View user's profile Send private message View poster's gallery Reply with quote
GaryBlack
 


Member Since: 02 Mar 2015
Location: Stafford
Posts: 2

England 

The Keeper wrote:
Had all of the sysmtems on my MY59 Discovery 4 2.7 TDV6 last week and followed the instructions from Stevie B in this thread...

1) Find a long straight and quiet section of road.Neutral
2) Select LOW Ratio.Shocked
3) Reverse for about 200 yards or until you get the beep and the R on the dash gear number indicator. And then a tiny bit more for good luck. Stop, then...Neutral
4) Go forwards in 1st until number appears. Clutch pedal must be fully raised each time.Exclamation
5) Then up through the Gears waiting for each of the numbers to appear. Do not skip any gears!Mad
6) Stop at 6th, back into neutral, switch off engine.Confused
7) After a brief rest, I took a couple of minutes just to make sure all the bad ju ju was gone and to have a quick wee as it was just all too exciting.Whistle
Cool Restart and select High Ratio and you're on your way..Laughing

All now sorted Very Happy Respect Stevie Bow down


Dear all, Thanks for the advice, my local gagrage wanted to replace the parking brake unit for £900+. I followed the advice as the car also presented other problems and everything now works. Thank you.
  
Post #176507518th Jan 2017 7:52 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 7 of 7 <1234567
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site