Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Technical (D3)

My Disco cut out whilst driving and won't start?!
Post Reply  Down to end
Page 3 of 4 <1234>
Gareth
Site Moderator 


Member Since: 07 Dec 2004
Location: Bramhall
Posts: 22817

United Kingdom 2013 Discovery 4 3.0 SDV6 HSE Lux Auto Fuji WhiteDiscovery 4

Added to Wiki also. Let us know if you are successful in fixing this Thumbs Up
  
Post #127659829th Apr 2014 6:53 am
View user's profile Send private message View poster's gallery Reply with quote
TDi.Si
 


Member Since: 09 May 2013
Location: Glos, GL6
Posts: 44

United Kingdom 2006 Discovery 3 TDV6 S Manual Bonatti GreyDiscovery 3

So started the connector bypassing. Did the white connector first:
Click image to enlarge


Then started on the black connector, but found someone has already been there! One pair of twisted wires has been cut and joined and a red wire cut and joined, all 3 into plain black cables, so I followed them along the loom, they join back into the original colours just before the EPB connector. Then it started raining!
Click image to enlarge


I'll check the continuity along them before I join them and hope it's a good job, I'm 99% sure I know where this was done (yes it was a main dealer) as I bought the car from friends. Then I just need to put the whole car back together and hope it works, don't like it looking like this! Shocked
Click image to enlarge


Admin note: this post has had its images recovered from a money grabbing photo hosting site and reinstated Mr. Green
  
Post #127701729th Apr 2014 7:21 pm
View user's profile Send private message View poster's gallery Reply with quote
TDi.Si
 


Member Since: 09 May 2013
Location: Glos, GL6
Posts: 44

United Kingdom 2006 Discovery 3 TDV6 S Manual Bonatti GreyDiscovery 3

This seams to be fixed now! Touch wood! Laughing
The red wire which is joined in the photo was broken at the plug where someone had split the insulation, all soldered up & heatshrunk now. I filled the back of the EPB connector with silicone grease before re assembling it. Also my hand brake fault has gone again, must be the red wire causing that.

Whilst it was apart I changed the washer bottle as it had split along the seam, seamed a good time to do it! Hopefully that's all it'll need for the MOT which is looming!

Thanks again to everyone for all your help! Would still be in bits if it wasn't for you! Thumbs Up
  
Post #12795234th May 2014 10:04 pm
View user's profile Send private message View poster's gallery Reply with quote
Kingmav66
 


Member Since: 20 Jul 2010
Location: Gloucestershire
Posts: 1336

England 2006 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

Well done Thumbs Up Thumbs Up
If I have a wiring fault, I know who to call.... Laughing We're in GL2
  
Post #12795424th May 2014 10:59 pm
View user's profile Send private message View poster's gallery Reply with quote
MXB
 


Member Since: 27 Jan 2015
Location: Staffordshire
Posts: 13

United Kingdom 2005 Discovery 3 TDV6 SE Auto Bonatti GreyDiscovery 3

Makes you wonder that in another 10-15 years time when most of these electrical connectors have broken down, how many Disco 3'S will be broken/scrapped because they cannot trace the faults? No good sending it to the stealers as 1) they probably won't find it and 2) It will cost £1,000 to not find the fault Sad
  
Post #145778113th Apr 2015 5:51 pm
View user's profile Send private message View poster's gallery Reply with quote
newtoD4
 


Member Since: 25 Aug 2015
Location: Accra, Ghana
Posts: 7


Driving a D4 now, and the more I read stories like this one, the more I worry about long term ownership of the car. Why make a car so freaking complex?.... you're effectively driving around in a laptop computer with these vehicles.
  
Post #152153629th Aug 2015 10:05 am
View user's profile Send private message View poster's gallery Reply with quote
DG
Site Moderator 


Member Since: 12 Dec 2005
Location: The Gaff
Posts: 43327

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

D4 is much more stale ...don't read D3 threads Wink Laughing
  
Post #152154229th Aug 2015 10:25 am
View user's profile Send private message View poster's gallery Reply with quote
NJSS
 


Member Since: 06 May 2009
Location: Catherington, Hampshire.
Posts: 5677

United Kingdom 2016 Discovery 4 TDV6 Landmark LE Auto Waitomo GreyDiscovery 4

"stale" Rolling Eyes
 2016 Discovery 4 Landmark
1973 MG B GT V8 - 3.9L John Eales engine, 5 speed R380 gearbox, owned from new
1959 MGA roadster - 1.9L Peter Burgess Engine - 5 speed gearbox
Past LRs - Multiple FFRs, Discos & a Series I - some petrol, some diesel 
 
Post #152158429th Aug 2015 12:34 pm
View user's profile Send private message View poster's gallery Reply with quote
newtoD4
 


Member Since: 25 Aug 2015
Location: Accra, Ghana
Posts: 7


Stale?? Meaning in this context being??

I assumed the D4 is basically a D3 with some cosmetic changes.
Were all the issues of the D3 ironed out with the D4, making it a more reliable vehicle?
Just asking here. Thanks.
  
Post #152161129th Aug 2015 2:49 pm
View user's profile Send private message View poster's gallery Reply with quote
DG
Site Moderator 


Member Since: 12 Dec 2005
Location: The Gaff
Posts: 43327

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

Stable Embarassed Rolling with laughter
  
Post #152161929th Aug 2015 3:17 pm
View user's profile Send private message View poster's gallery Reply with quote
sinisa.spasov
 


Member Since: 01 Jan 2016
Location: Skopje
Posts: 2

Macedonia 2008 Discovery 3 TDV6 SE Auto Stornoway GreyDiscovery 3
Engine failure

Discovery 3, 2.7TD engine. Just suffered sudden engine failure without previous announcement(no signs that this can happen) with 175.000 km on the clock. No warning lights before the failure. Vehicle was regularly maintained, oil and filters changed on time. Belt set changed on 160.000km.
Can not say if extended oil warning light for 2-3 seconds when first morning engine starting ever since I drive this vehicle (from 120.000km) has something incommon with the failure.
Is there any goodwill offer for new engine by Land rover?
  
Post #15866593rd Jan 2016 4:27 pm
View user's profile Send private message View poster's gallery Reply with quote
gidiLR3
 


Member Since: 19 Jan 2017
Location: London
Posts: 2

United Kingdom 2005 Discovery 3 TDV6 Base 5 Seat Auto Adriatic BlueDiscovery 3

Here is my very first experience with a Discovery 3 after wanting one for so long
Evil or Very Mad Evil or Very Mad Evil or Very Mad Note I say "a Discovery 3" and not my Discovery 3 Evil or Very Mad Evil or Very Mad Evil or Very Mad

driving happily along the German Autobahn A3 had just filled up the tank with diesel when all of a sudden it cut out and lowered, hazards started flashing, interior lights came on, doors unlocked, lots of lights on the dash, E in gear display. Suspension lowered, hdc fault, engine system fault, system fault special programs not available, when I managed to get on to the Hard shoulder the handbrake came up.

this is where I spent the next 5 hours in -3degree centigrades freezing my Censored off
waiting for the ADAC ..... europes version of the AA or RAC
4hours in to my wait the Polizie turned up ..... Laughing Laughing Laughing I have never been so happy to see the police they stayed with me until I was recovered to the ADAC garage, and then dropped me off at a Hotel for the rest of the night
Next morning I had to be recovered again to the main LR dealer in Essen where I left the car as they could not take a look at it because there were so many LRs that had broken down.... 4more LR turned up on the back of ADAC lorries whilst i was there
  
Post #176571419th Jan 2017 1:26 pm
View user's profile Send private message View poster's gallery Reply with quote
Sloss
 


Member Since: 18 Aug 2013
Location: Aberdeenish
Posts: 1581

Scotland 2010 Discovery 4 3.0 TDV6 HSE Lux Auto Santorini BlackDiscovery 4

Mods: This might need its own thread?
 Stew,  
Post #176579419th Jan 2017 5:06 pm
View user's profile Send private message View poster's gallery Reply with quote
shanegtr
 


Member Since: 22 Aug 2014
Location: Pilbara - Western Australia
Posts: 101

Australia 2005 Discovery 3 TDV6 SE Auto Cairns BlueDiscovery 3

Dont know why I didnt find this thread earlier, but theres some similarities to an issue Im currently having. When mine faults it dosent cut the engine if its running, but the hazards come on and I hear the doors unlocking. If the cars off and this fault is active then the hazards still come on and the engine wont start.

One thing I failed to mention earlier as I didnt think it was related but after reading this thread it may be is I was seeing park brake faults flashing up on the dash every now and again so I guess the logical thing would be to add that to the list of areas to check out. Might be difficult as I have a long range tank installed which may need to be removed to access

Reference to my thread http://www.disco3.co.uk/forum/topic162102.html
  
Post #183914321st Jul 2017 4:58 am
View user's profile Send private message View poster's gallery Reply with quote
BrettKaz
 


Member Since: 11 Nov 2013
Location: Canberra
Posts: 172

Australia 2007 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

Shane, you haven't circled back to the chassis/body rear electrical connectors? The instrument cluster refurb didn't fix it?
  
Post #188147220th Nov 2017 7:53 am
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 3 of 4 <1234>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site