Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D3)

[Electrical] Gear selected not showing
Post Reply  Down to end
Page 3 of 5 <12345>
Stevie B
 


Member Since: 29 Jan 2011
Location: Cornwall
Posts: 10

United Kingdom 2005 Discovery 3 TDV6 S Manual Bonatti GreyDiscovery 3

Had this trouble with my Manual D3

Follow the thread

http://www.disco3.co.uk/forum/topic46472.html

Or just look under Manual Gearbox XYZ Sensor Failures in this forum..

If you've an Automatic I have nothing for you sorry.....

Good Luck...SB...
  
Post #75454931st Jan 2011 11:01 am
View user's profile Send private message View poster's gallery Reply with quote
yellodisco
 


Member Since: 17 Nov 2010
Location: Penicuik
Posts: 73

Scotland 2008 Discovery 3 TDV6 HSE Auto Tangiers OrangeDiscovery 3
Park Brake fault

Hi, I've got this problem on an HSE auto - warning on dash says park brake fault, the orange handbrake indicator stays on and the area that should show what gear its in is blank, unless I push lever into command shift when it says "sport" and shows no. of gear selected - reverse sensors are working Ok though. Does post above say that there is no workaround / reset solution for the auto?
Am I going to have to go to a dealers to have it reset? will that be covered under warranty, which only has 3 months left?
thanks for any advice, Alan
  
Post #76571322nd Feb 2011 11:56 pm
View user's profile Send private message View poster's gallery Reply with quote
gerrymclandy
 


Member Since: 27 Aug 2009
Location: Fife
Posts: 29

Scotland 2006 Discovery 3 TDV6 Base 5 Seat Manual Zambezi SilverDiscovery 3

I did what geoff suggested and infact just posted this a while ago probably on the wrong section got it from another thread then dashed out and tried it it worked

I went into the cinema car park went on into low gear and reversed foot fully off clutch then into high up all the gears and everything is working again bludy marvellous. Saved a few bob too Thumbs Up
 bought a 06, TDV6 on 28/08/09 loving every minute of it.. Had TDI & TD5s over the years now nothing compares to this beast.  
Post #76697325th Feb 2011 4:32 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
gerrymclandy
 


Member Since: 27 Aug 2009
Location: Fife
Posts: 29

Scotland 2006 Discovery 3 TDV6 Base 5 Seat Manual Zambezi SilverDiscovery 3
Re: Park Brake fault

yellodisco wrote:
Hi, I've got this problem on an HSE auto - warning on dash says park brake fault, the orange handbrake indicator stays on and the area that should show what gear its in is blank, unless I push lever into command shift when it says "sport" and shows no. of gear selected - reverse sensors are working Ok though. Does post above say that there is no workaround / reset solution for the auto?
Am I going to have to go to a dealers to have it reset? will that be covered under warranty, which only has 3 months left?
thanks for any advice, Alan

Not sure if it works for automatic but give it a go in reverse on low see what happens
 bought a 06, TDV6 on 28/08/09 loving every minute of it.. Had TDI & TD5s over the years now nothing compares to this beast.  
Post #76697525th Feb 2011 4:35 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
yellodisco
 


Member Since: 17 Nov 2010
Location: Penicuik
Posts: 73

Scotland 2008 Discovery 3 TDV6 HSE Auto Tangiers OrangeDiscovery 3

Thanks Gerry - tried it but still got warning message and light on - guess its a trip to the dealers then, Alan
  
Post #76860928th Feb 2011 10:40 pm
View user's profile Send private message View poster's gallery Reply with quote
NMProp
 


Member Since: 12 Apr 2011
Location: Londonderry
Posts: 3

Northern Ireland 2007 Discovery 3 TDV6 XS Manual Zambezi SilverDiscovery 3

100 miles and 2 days of Disco ownership before the automatic relase on the EPB failed along with gear selector and reversing sensors.

Up and running again thanks to this site Bow down
  
Post #78656215th Apr 2011 10:10 pm
View user's profile Send private message View poster's gallery Reply with quote
yellodisco
 


Member Since: 17 Nov 2010
Location: Penicuik
Posts: 73

Scotland 2008 Discovery 3 TDV6 HSE Auto Tangiers OrangeDiscovery 3
PArk brake fault

So, took it into dealers under warranty - diagnosis was wiring fault (rather than x-y sensor as suggsted through various posts on here). THe wiring fault was fixed and I no longer have the "park brake fault" showing on dash, also reversing lights are working (although they may have been working all along). Only thing is that dashboard still isn't displaying what gear its in, except when in sport / command shift mode. Presumably it should also display what gear its in in full auto mode. Can anyone confirm this as its due tp go back to dealer again for another (unrelated) warranty fix and if it should be displaying gears I'll ask for that to be fixed at same time. Thanks again, Alan
  
Post #79824118th May 2011 10:22 pm
View user's profile Send private message View poster's gallery Reply with quote
Dave T
 


Member Since: 03 Jul 2009
Location: Glasgow
Posts: 5225

England 2016 Discovery 4 3.0 SDV6 Graphite LE Auto Santorini BlackDiscovery 4

Alan, is the XYZ Sensor not just for a manual? Question
 2016 D4 Graphite Santorini Black
1994 Defender 90
2012 D4 XS Orkney Grey missing it already
2005 D3 S Maya Gold - Gone but never forgotten

Convoy for Heroes 2011

You Tube vids
http://www.youtube.com/user/msdtdave1

photos
http://s243.photobucket.com/albums/ff15/davetomlin/Off%20Roading/ 
 
Post #79826819th May 2011 6:07 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
DaveS
 


Member Since: 15 Aug 2009
Location: Weybridge
Posts: 241

United Kingdom 2005 Discovery 3 TDV6 S Auto Java BlackDiscovery 3
Re: PArk brake fault

yellodisco wrote:
Only thing is that dashboard still isn't displaying what gear its in, except when in sport / command shift mode. Presumably it should also display what gear its in in full auto mode. Can anyone confirm this as its due tp go back to dealer again for another (unrelated) warranty fix and if it should be displaying gears I'll ask for that to be fixed at same time. Thanks again, Alan


As far as I know, the automatic will simply display "D" when in normal drive mode. This is based on my '05 model.
  
Post #79842619th May 2011 1:35 pm
View user's profile Send private message View poster's gallery Reply with quote
yellodisco
 


Member Since: 17 Nov 2010
Location: Penicuik
Posts: 73

Scotland 2008 Discovery 3 TDV6 HSE Auto Tangiers OrangeDiscovery 3

THanks Dave & Dave!
yes. looks like its only supposed to show gear numbers when in command shift, otherwise just a "d" - still trying to understand all of the technicalities & complexity of this big beast (which I'm loving!)
Dave T - hope everything going well with yours again.
Alan
  
Post #79909521st May 2011 10:49 pm
View user's profile Send private message View poster's gallery Reply with quote
meetzejt
 


Member Since: 20 Sep 2010
Location: South Carolina
Posts: 36

United States 2006 LR3 4.4 V8 SE Auto Maya GoldLR3

Also wanted to mention (I have an auto V8 petrol) that I had total loss of my command shift/no numbers showing/no lights on the gearshift console due to a bad circuit board INSIDE of the gear selector while working for LR.

Probably caused by the previous owner spilling something in there.... Replaced the board with a donor one from a RRS and all problems were solved. Know these things tend to short out due to spillage often.

Too bad the board cannot (as far as I'm aware) be purchased separately - LR will only sell you the ENTIRE gear selector!
  
Post #8153508th Jul 2011 7:11 pm
View user's profile Send private message View poster's gallery Reply with quote
d3david
 


Member Since: 08 Sep 2011
Location: Central South
Posts: 2

England 2007 Discovery 3 TDV6 XS Manual Buckingham BlueDiscovery 3
D3 Manual Gear indicator

Had a problem with the rear parking sensors, auto handbrake release and gear indicator on a go slow. This all stemed from being stuck in very heavy traffic on a French motorway and a lot of 1st gear and clutchwork. The fault showed up as a parking brake fault. Took it to main dealer who gave me an estimate to replace the reverse light switch and parking brake actuator for £1000.00!! Mmmm I thought, read the attached forum and gave it a try! Selected reverse then moved up through the gears sequentially coming to a stop in 6th, taking the key out and waiting for the park brake light to go out and hey presto - problem solved! Thank you D3 Forum Very Happy
  
Post #83449713th Sep 2011 8:11 am
View user's profile Send private message View poster's gallery Reply with quote
gazjacko
 


Member Since: 14 Jan 2012
Location: Portsmouth-ish
Posts: 139

United Kingdom 2005 Discovery 3 TDV6 SE Manual Java BlackDiscovery 3

this is what the internet and forums are for!!!!
top advice, cleared hesitant running and amber 'P' light too!
  
Post #93188715th May 2012 7:00 pm
View user's profile Send private message View poster's gallery Reply with quote
Andyred90
 


Member Since: 10 Mar 2010
Location: Wantage
Posts: 544

2005 Discovery 3 TDV6 S Manual Zambezi SilverDiscovery 3

Had the parking brake failure come up on mine and it didn't clear after resetting the xy sensor......

Turned out to be a battery issue as I had recently replaced the battery with a correct spec non genuine version.

The time that the engine took to crank was a fraction of a second too long and this triggered the fault. as I was sceptical I swapped the non genuine battery for another one of the same make and the problem continued so I returned the battery and bought the genuine LR battery, rest the sensor and everything has been fine since the change to genuine battery!
  
Post #99307522nd Oct 2012 10:35 pm
View user's profile Send private message View poster's gallery Reply with quote
bigtam64
 


Member Since: 19 Nov 2009
Location: Leeds
Posts: 192

United Kingdom 2005 Discovery 3 TDV6 Base 7 Seat Manual Santorini BlackDiscovery 3
park brake amber light,no gear display,.

hi guys
I am at the moment on the isle of skye visiting for new year have got to get back to leeds on wednesday.
I have a problem with
last week before i left leeds I had a park brake fault come up I have had adjustments done but I still have amber light on the dash display.going in to adventure next week for reseting of display.
I have noticed over the last couple of days that the gear slected display has a time lag of about 5 seconds not an issue I can live with that on the short term.
I know have no reversing lights and a slipping clutch.
I have had a look at previous posts and I am hoping the going through the gear re teach process will solve my problems until i can get back to Leeds on wednesday.

Any one had any issues the same and is it going to be as simple as I hope it could be.

Help
Big Cry Big Cry Big Cry
!
 Weekends are to short
Egr valves removed 
 
Post #102650130th Dec 2012 11:30 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 3 of 5 <12345>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site