Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > In Car Electronics (D3)

Radio won't power up
Post Reply  Down to end
Page 1 of 1
Philnic
 


Member Since: 09 May 2018
Location: Theydon Bois, Essex
Posts: 45

United Kingdom 2006 Discovery 3 TDV6 Metropolis LE Auto Java BlackDiscovery 3
Radio won't power up

Guys I need some inspiration for where to look to diagnose, here is the story:

I have a top line HK stereo with 6 disc in the front. I run an AliExpress Android tablet instead of the nav screen, have done for a few years, all good. Recently I had a problem with the screen, basically dodgy connection on the switched live connection that I had to remake. In doing so I disturbed the screen, radio and heater switch panel.

All fixed, tested and working. So then I pack it all back in, all the cables need a little tidying to get the H panel back on etc. Once all put back, its not working. As in the radio doesn't power up and its taken the screen with it.

Of course I have had it all out again, checked connections (it all is done with proper adaptors, nothing on the radio is manual connections), put all together, twice. No joy. Replaced android screen with original to remove any of the new wiring - again, no joy.

Checked fuses, 53 is fine, and has power. Changed the radio and cigarette lighter relays. All other audio system related fuses are fine.

Error codes show lost communication with Audio Module.

I don't now know what to check next? Could I have blown the radio unit? Maybe, but how to check without having a spare?

Am I missing something that I should be checking? Which is the live power cable on the loom leading to the head unit? I could check that, if that's powered then surely the radio should at least power up?
 2006 Java Black Metropolis - my first dip into the D3 world!  
Post #23497616th Oct 2023 2:20 pm
View user's profile Send private message View poster's gallery Reply with quote
Philnic
 


Member Since: 09 May 2018
Location: Theydon Bois, Essex
Posts: 45

United Kingdom 2006 Discovery 3 TDV6 Metropolis LE Auto Java BlackDiscovery 3

Update to the above - found the wires to the back of the radio, no supply. But fuse 53 is live, so I am assuming I have either a break between the two, or something else is killing it.

I did have an error:

B1C62-12 - Battery saver relay output circuit - General electrical failure - circuit short to battery (68)
( on 03-03-2027 23:26:22 at 169211 mi )

That could be killing power, but clearing it has no impact.

Also:
B1B70-81 - Local interconnection network bus circuit 2 - Bus signal/message failure - invalid serial data received (28)
( on 04-03-2027 14:31:03 at 169298 mi )
 2006 Java Black Metropolis - my first dip into the D3 world!  
Post #23497756th Oct 2023 3:46 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 10414

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Do reading lights and vanity sunvisor mirror lights work ? If not thats what the relay saver fault code is telling you
  
Post #23497916th Oct 2023 5:15 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 10414

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Check the thick blue purple wire at the radio for power.
  
Post #23497956th Oct 2023 6:39 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site