Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Webasto Fuel Burning Heater

Help please
Post Reply  Down to end
Page 1 of 1
marco 110
 


Member Since: 15 Nov 2009
Location: Albertville Savoie. France
Posts: 897

France 2012 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4
Help please

Hello.
I need the Guru of Webasto ..

Had trouble with my D4 , can't start the webasto...try all the tips and reset and purge with my iidtool .
And always had the same fault..




I found strange that the basto always fan a long period all time I'll try to start it...
Seems the comportement is different of the webasto on my D3 ?!

What can I check ? Do,the webasto software vvt work on the EVO ? With the same loom ?

Ho , and all my apologies for my bad English... Bow down
 marco.

http://www.youtube.com/user/marcsteph110?feature=mhum

Ex : D3 tdv6
D4 sdv6 HSE , high beam assist , surround cam, tv , and a lot of nice stuff..

 
 
Post #17567452nd Jan 2017 12:40 pm
View user's profile Send private message View poster's gallery Reply with quote
Bodsy
Site Sponsor 


Member Since: 06 Nov 2006
Location: In the Clubhouse
Posts: 20625

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Java BlackDiscovery 3

Same software should work Marco.
If it gets to the point where the glow plug kicks in and that it then sounds as though it's trying to start up (about 40secinds into test) try blowing air into the air intake.
 FS Tree Sliders
Bodsys Brake Bible

D4/D3 Remote heat kits
BAS Remaps/ EGR Blank

Clock/ SNOTM /3Flash / 4x4Info /BT Update /Service Reset/Error Codes / Gearbox Reset
See It Here 
 
Post #17567522nd Jan 2017 12:56 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
marco 110
 


Member Since: 15 Nov 2009
Location: Albertville Savoie. France
Posts: 897

France 2012 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

Thanks for advice Ian , but already try it...

I noticed , with my iidtool , that the fuel pump never come on ?!?..

I'd test it , she's ok , fuel priming work fine..

I don't understand...
That's what I had in the live value:

-fan come imediatly at high speed for 1/2 min
-glow plug come and shut down imediatly
- fan come again for the 'cool down'...


What's happened ?!?
 marco.

http://www.youtube.com/user/marcsteph110?feature=mhum

Ex : D3 tdv6
D4 sdv6 HSE , high beam assist , surround cam, tv , and a lot of nice stuff..

 
 
Post #17576994th Jan 2017 2:05 pm
View user's profile Send private message View poster's gallery Reply with quote
A1GSS
 


Member Since: 12 Sep 2010
Location: Saffron Walden, Essex
Posts: 4197

England 

Blocked fuel line...? Try blowing the webasto fuel line through with compressed air. Fixed it on my D3 which had very similar symptoms (unit may differ though)
 Graham

New: 17MY Evoque 2.0 TD4 SE Tech Loire Blue / Cirrus Grey
Going strong: 11MY Audi A8 3.0 TDi Quattro Black / Black
Gone Big Cry 08MY TDV6 Discovery 3 XS in Stornoway Grey / Alpaca
Gone: 08MY TDV8 FFRR Vogue in Stornoway Grey / Jet 
 
Post #17577034th Jan 2017 2:07 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
marco 110
 


Member Since: 15 Nov 2009
Location: Albertville Savoie. France
Posts: 897

France 2012 Discovery 4 3.0 SDV6 HSE Auto Fuji WhiteDiscovery 4

Last news.

Thanks Martin for the loom Thumbs Up

So , I'd plug my laptop and run the ttv webasto software ..
Clear the fault.
Run the glow plug at 100% for 20 sec , fan at 200% for cool down , and again , and again..

Lot of smoke only with the glow on Whistle ..

Run the car , and....yep , he's alive...lot of smoke for 15 min...do a run with get car warm... Stop it , restart and all if ok , webasto restart normally... So : Thumbs Up

First real test tomorrow at 3am with timed climate ..
 marco.

http://www.youtube.com/user/marcsteph110?feature=mhum

Ex : D3 tdv6
D4 sdv6 HSE , high beam assist , surround cam, tv , and a lot of nice stuff..

 
 
Post #176221512th Jan 2017 4:49 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO3.CO.UK on twitter

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site