Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Maintenance & Mods (D4)

D4 3.0 oil change - 'How To'
Post Reply  Down to end
Page 3 of 5 <12345>
Stevie D
 


Member Since: 10 Sep 2009
Location: Bishops Stortford
Posts: 276

England 2013 Discovery 4 3.0 SDV6 XS Auto Santorini BlackDiscovery 4

update:

I removed the Sealey middle tube from its rubber joint and it fitted perfectly over the extraction tube.

Steve
 Discovery 3 HSE - sold
Defender 90 TD5 Station Wagon - sold
Mini Cooper Clubman
Discovery 4 XS 
 
Post #177717411th Feb 2017 3:10 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
cosmic329
 


Member Since: 17 Dec 2013
Location: Chichester
Posts: 177

England 2012 Discovery 4 3.0 SDV6 HSE Auto Indus SilverDiscovery 4

Great 'How-to' guide Thumbs Up .

Stupid question but how do I reset the Oil Service Indicator with my IIDBT tool? It is a D4 MY11 (12 model) and the only option I can find in the App is under the Instrument Pack menu called 'Service Interval Reset'. I thought there was a separate option for just the Oil Service? I am changing the oil in-between the normal services so as I don't want to reset the reminder for the full service.
 
Discovery 4 SDV6 HSE '61 - Remote climate kit, Heated steering wheel upgrade, 2nd battery mod, upgraded grill and spots, LED interior lights, LED reverse lights, Foglight DRLs. - now gone Sad

Discovery 3 Tdv6 HSE '56 - gone
Defender 90 Tomb Raider '51 - gone
Defender 110 XS '54 - gone 
 
Post #178117320th Feb 2017 1:35 pm
View user's profile Send private message View poster's gallery Reply with quote
SGH
 


Member Since: 21 Dec 2009
Location: Hellingly. East Sussex.
Posts: 1178

United Kingdom 2015 Discovery 4 3.0 SDV6 HSE Lux Auto Montalcino RedDiscovery 4

Don't know if correct I just reset service.
 Defender 300Tdi 110 HCP - Keswick Green
Discovery 4 SDV6 HSE LUX - Montalcino Red/Black Pack - Gone
Connect L2 Double Cab - Moondust Silver
Connect L1 - Moondust Silver
VW California Ocean 150PS DSG - Reflex Silver 
 
Post #178117620th Feb 2017 1:38 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
robpenrose
 


Member Since: 12 Jan 2016
Location: Surrey / SW London
Posts: 1982

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Stornoway GreyDiscovery 4

cosmic329 wrote:
Great 'How-to' guide Thumbs Up .

Stupid question but how do I reset the Oil Service Indicator with my IIDBT tool? It is a D4 MY11 (12 model) and the only option I can find in the App is under the Instrument Pack menu called 'Service Interval Reset'. I thought there was a separate option for just the Oil Service? I am changing the oil in-between the normal services so as I don't want to reset the reminder for the full service.


Yes I was wondering that. Ive read somewhere the D4 monitors the oil level/fuel dilution level so its important to reset it? Not sure whats correct, so would be good to get clarification on this. Thumbs Up
 

Current: D4 HSE
Previous: BMW Z4M Coupe
Previous: Land Rover Defender 90 CSW Td5
Previous: Land Rover Discovery Td5 ES 
 
Post #178117920th Feb 2017 1:40 pm
View user's profile Send private message View poster's gallery Reply with quote
Washwipe
 


Member Since: 19 Apr 2013
Location: Bucks Oxon Herts Border
Posts: 3096

England 

Of use Question

http://www.disco4.com/forum/topic139151.html?
  
Post #178130720th Feb 2017 6:24 pm
View user's profile Send private message View poster's gallery Reply with quote
cosmic329
 


Member Since: 17 Dec 2013
Location: Chichester
Posts: 177

England 2012 Discovery 4 3.0 SDV6 HSE Auto Indus SilverDiscovery 4

Thanks for all the replies. I have been through that thread and it suggests that there is a separate option to reset just the oil service indicator - I can't see that option On the IIDBT tool. Hence my question Very Happy
 
Discovery 4 SDV6 HSE '61 - Remote climate kit, Heated steering wheel upgrade, 2nd battery mod, upgraded grill and spots, LED interior lights, LED reverse lights, Foglight DRLs. - now gone Sad

Discovery 3 Tdv6 HSE '56 - gone
Defender 90 Tomb Raider '51 - gone
Defender 110 XS '54 - gone 
 
Post #178132020th Feb 2017 6:56 pm
View user's profile Send private message View poster's gallery Reply with quote
Washwipe
 


Member Since: 19 Apr 2013
Location: Bucks Oxon Herts Border
Posts: 3096

England 

Is it a sub section of the Service Reset Question
  
Post #178132420th Feb 2017 7:11 pm
View user's profile Send private message View poster's gallery Reply with quote
cosmic329
 


Member Since: 17 Dec 2013
Location: Chichester
Posts: 177

England 2012 Discovery 4 3.0 SDV6 HSE Auto Indus SilverDiscovery 4

Not sure as I'm too nervous to choose the option in case it just resets the full service indicator Shocked . I was hoping someone would know Very Happy
 
Discovery 4 SDV6 HSE '61 - Remote climate kit, Heated steering wheel upgrade, 2nd battery mod, upgraded grill and spots, LED interior lights, LED reverse lights, Foglight DRLs. - now gone Sad

Discovery 3 Tdv6 HSE '56 - gone
Defender 90 Tomb Raider '51 - gone
Defender 110 XS '54 - gone 
 
Post #178135420th Feb 2017 8:10 pm
View user's profile Send private message View poster's gallery Reply with quote
sceh
 


Member Since: 14 Sep 2011
Location: annecy
Posts: 48

France 2011 Discovery 4 3.0 TDV6 S Auto Chawton WhiteDiscovery 4
Getting the filter out..

So has anybody found the trick to get the filter out of the plastic body without breaking anything. On the 2.7 engine you need a tool but NOT on the 3.0 according to the WS manual.
So, brute force??


  
Post #180529519th Apr 2017 9:04 am
View user's profile Send private message View poster's gallery Reply with quote
swansty
 


Member Since: 21 Sep 2008
Location: Northern Ireland
Posts: 819

Northern Ireland 2010 Discovery 4 3.0 TDV6 XS Auto Zermatt SilverDiscovery 4

its been discussed a few times on here. Most use a hollow pipe to push down the centre of the filter and release the 4 spring clips. The pipe I use has ID of 18.55mm and OD is 25mm. IIRC the tubing came off a cheap eBay syphon.
  
Post #180529819th Apr 2017 9:11 am
View user's profile Send private message View poster's gallery Reply with quote
cosmic329
 


Member Since: 17 Dec 2013
Location: Chichester
Posts: 177

England 2012 Discovery 4 3.0 SDV6 HSE Auto Indus SilverDiscovery 4

I pulled the filter insert (don't pull the plastic tube that is inside) gradually on each side and the turned it and did the other. If you keep pulling each side up as much as you can and then turn and do the other, with a bit of wiggling and pulling it eventually comes out. I had no joy pushing the clips with screwdrivers or tubing (but that might be that I could not find the exact size that fitted).
 
Discovery 4 SDV6 HSE '61 - Remote climate kit, Heated steering wheel upgrade, 2nd battery mod, upgraded grill and spots, LED interior lights, LED reverse lights, Foglight DRLs. - now gone Sad

Discovery 3 Tdv6 HSE '56 - gone
Defender 90 Tomb Raider '51 - gone
Defender 110 XS '54 - gone 
 
Post #180531119th Apr 2017 9:41 am
View user's profile Send private message View poster's gallery Reply with quote
sceh
 


Member Since: 14 Sep 2011
Location: annecy
Posts: 48

France 2011 Discovery 4 3.0 TDV6 S Auto Chawton WhiteDiscovery 4

When I first tried to remove the filter it was obviously oily and slippery. A small screwdrive on one side with very little effort removed it. This applies to the 3.0 engine only - the 2.7 needs a special puller
  
Post #180665722nd Apr 2017 4:16 pm
View user's profile Send private message View poster's gallery Reply with quote
Pigscovery
 


Member Since: 14 Aug 2014
Location: Worcestershire
Posts: 28

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Ipanema SandDiscovery 4

Just changing My 2010 D4 oil & filter. 3.0 TDV6

After reading this 'How To' topic I was surprised to see my filter was left behind in the base after unscrewing and lifting off the plastic cover. There was no plastic 'cage' inside the filter , so nothing to retain the filter in position other than the metal housing below.

I am suspecting that previous 'Main Dealer' and one 'Indy' service have discarded the cage/tube that sits in the centre of the filter.

Also, the only 'o' ring that came with new filter (genuine) was for the housing screw thread seal to the metal base. No O ring inside the housing.

I am reluctant now to put it all back together until I know if this was a factory mod or a dealer 'bodge' !

Anyone else had what I am finding ?

As the Disco 4 TDV6 was only for a short run (maybe 18 months) before SDV6 came about then mine may be different / no tube/cage inside the filter hole..

ARGH nothing ever straight forward Sad
  
Post #19231556th Mar 2018 5:33 pm
View user's profile Send private message View poster's gallery Reply with quote
Pigscovery
 


Member Since: 14 Aug 2014
Location: Worcestershire
Posts: 28

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Ipanema SandDiscovery 4

Aha, found this;
Reference SSM60017
Models Discovery 4 / L319
Range Rover Sport / L320

Title 3.0 TDV6 Oil Filter Cap Centre Support
Category Engine
Last modified 17-Oct-2012 00:00:00
Symptom 499000 Basic Engine
Content Issue:

The oil filter centre support which is fitted internal to the oil filter cap housing is inadvertently being discarded during a routine Service when the oil filter element is replaced on 3.0 TDV6 engine derivatives.

Action:

After the filter element is replaced please check the oil filter cap housing and ensure the centre support is retained in place before refitting the cap assembly. Failure to ensure the centre support is in place reduces the clamp height of the element which can potentially affect the closure of the internal drain valve. This could lead to an oil leak resulting in excessive exhaust smoke.

For reference the current part number of the oil filter element is LR013148 and the oil filter cover cap part number is LR013147. Please always refer to Microcat for up to date part number information.


So.. previous service(s) left it out. Considering age of the bulliten, this is disgusting behaviour, but not surprising !. I'll order a new cap. No leaks yet but maybe I've been lucky, and my new filter may be affecting the drain valve.
  
Post #19233387th Mar 2018 12:53 am
View user's profile Send private message View poster's gallery Reply with quote
Pigscovery
 


Member Since: 14 Aug 2014
Location: Worcestershire
Posts: 28

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Ipanema SandDiscovery 4
update

Purchased new Filter Cap, only £20 from main dealer which was a pleasant surprise ! See images showing the centre support tube, which is missing from mine.
Upon inspection, it is clear that the filter will be pushed further (maybe by 5mm) into the oil filter housing when screwed onto the car, confirming what the LR Bulletin states.
When I changed my oil I did notice that the pump housing still had 300ml or so left which I sucked out with the Vac pump to empty it. This also tallies with the LR Bulletin about the drain valve not operating correctly without the support tube in place.

Angry that the last garage either discarded it at worst or did not do anything about it being missing I have emailed them for a response, in case any damage has been caused in the last 12 months. Filter may not have been filtering !

They may not have even changed the filter which is unforgivable (fraud as it appears on my invoice).

Sad that DIY'ers do a more thorough job than some main agents/indies.


Notice 4 clips at base , holding it in....



  
Post #19238458th Mar 2018 2:36 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 3 of 5 <12345>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2021 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site