Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > General (D4)

Restricted performance intermittent - clears after restart
Post Reply  Down to end
Page 1 of 1
skinda0
 


Member Since: 11 Dec 2023
Location: Kent
Posts: 15

United Kingdom 2016 Discovery 4 3.0 SDV6 HSE Auto Corris GreyDiscovery 4
Restricted performance intermittent - clears after restart

I had a spate of the restricted performance message coming up a little while ago with a few other errors (gearbox fault), and this all seemed to be related to a weak battery. Since replacing the battery, I haven't had the error, until yesterday.

When fitting the new battery, I did reset the BMS, which I believe will perform a discharge cycle to 75%. When reading codes this morning, I noticed that while the engine was running, the IID tool was only reading 12/12.2V.

Reading faults I didn't get anything relating to the restricted performance message, but enabling one of the options on the advanced tab (pending and one other, can't remember what I selected now!) I got the following messages:

Standard Faults Read:
Click image to enlarge


Faults read with extra options:
Click image to enlarge



I am wondering if it is battery related still, but the intercooler pipe adaptor had blown off previously. I am yet to check it but I am wondering if it has come loose again? I also noticed a small wear mark on the intercooler hose near the radiator. I don't think it has gone through, but could this be a possible cause as well?

Edit: It also appears the Timed Climate button is now greyed out!

Thanks
 2016 Discovery 4 HSE
2011 Nissan Pathfinder 
 
Post #236199214th Feb 2024 8:37 am
View user's profile Send private message View poster's gallery Reply with quote
itsaguything
 


Member Since: 20 Dec 2023
Location: Manotick, On
Posts: 162

Canada 2015 LR4 3.0 SCV6 HSE Lux Auto Aintree GreenLR4

You are right in assuming that 12.2 is inadequate.

I would charge the battery whilst not connected to the vehicle to 100%, then attach to vehicle and reset bms.
 2015 LR4 HSE Lux Aintree Green
2013 LR2 HSE Radiance Red
2007 XKR Jaguar Racing Green
2005 XJR Jaguar Racing Green
2002 S-Type R British Racing Green 
 
Post #236200314th Feb 2024 12:29 pm
View user's profile Send private message View poster's gallery Reply with quote
skinda0
 


Member Since: 11 Dec 2023
Location: Kent
Posts: 15

United Kingdom 2016 Discovery 4 3.0 SDV6 HSE Auto Corris GreyDiscovery 4

I believe I have located the issue, hopefully.

The 90 bend on the intercooler hose had popped off again and on inspection the O ring has been deformed. However, when refitting it, I noticed it still did not seat correctly. It turns out, the hose clip on the coolant pipe next to the elbow was fouling on the housing. This has potentially meant that it has not seated correctly all the time it has been in that position. I rotated the clip round and the body of the elbow is now perpendicular to the throttle body!

Time to order an o-ring and replace.

Battery was recharged and fitted. This seems to have improved the voltage.
 2016 Discovery 4 HSE
2011 Nissan Pathfinder 
 
Post #236240619th Feb 2024 9:11 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site