Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Technical (D4)

Replaced coolant expansion tank and car failed on highway
Post Reply  Down to end
Page 2 of 2 <12
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4

Car back from rebuild and near on £7k .... and around 10 weeks turnaround.

Block with 4 new sleeves, new crank, internals, new turbos. Full recon of heads and replacement of some bent valves.. (I have no idea if oem - but was told / sold it was so).

Car now has the P1247 code and low boost and in Limp mode. Cursory inspection of engine yields the following mess. How guys can put an engine together with this attention to detail and dirt is beyond me.

My question is what is the part number for the hose that clips into the housing that holds the IAT sensor. This has sheared / broken off and the patch rubber hose is just not up to the boost. (IMG 1123)

Also why do my images not appear in the post ? Only the links?


 

Last edited by stevebez on 18th Apr 2022 1:54 pm. Edited 1 time in total 
Post #228815616th Apr 2022 10:54 am
View user's profile Send private message View poster's gallery Reply with quote
Scott #55
 


Member Since: 15 Apr 2015
Location: Glasgow
Posts: 1554

Ukraine 2010 Discovery 4 3.0 TDV6 HSE Auto Nara BronzeDiscovery 4

The content of your images look like URLs (web pages). Try uploading them with the Img tags? Copy the pictures to your desktop then 'Choose photos' from the button under the box where you type your text.

May well be teaching my granny to suck eggs.
 2014 - D4 2010 HSE Nara Bronze
2012 - FL2 2009 GS Stornoway Grey
2001 - VW Passat Estate Inky Blue
1999 - Ford Mondeo Light Blue
1998 - Rover 25 Red 
 
Post #228816216th Apr 2022 11:42 am
View user's profile Send private message View poster's gallery Reply with quote
CIO
 


Member Since: 06 Mar 2018
Location: Bahrain
Posts: 66

Bahrain 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Santorini BlackDiscovery 4

stevebez wrote:
Car back from rebuild and near on £7k .... and around 10 weeks turnaround.

Block with 4 new sleeves, new crank, internals, new turbos. Full recon of heads and replacement of some bent valves.. (I have no idea if oem - but was told / sold it was so).


Who did the rebuild?
 Chris
--
2016 D4 Landmark in the UK. 2014 LR4 SE in Bahrain. 
 
Post #228826817th Apr 2022 7:13 am
View user's profile Send private message View poster's gallery Reply with quote
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4

At this stage Id rather not say as we still in the phase of rectifying some “issues”.

Car runs rough on cold start … think its either injectors or glow plugs .. car runs well when warm though.

Im thinking of coding the injectors up again and see if that helps my sense is these guys didn't do this (supposedly changed one injector) - they were in awe when I showed up with my code checker when I picked up car….. Im running some injector cleaner through the car now but think at least one more got damaged when the engine melted. One thing I can say is I got completely flummoxed by the smart website these guys had making me think they were a pro outfit. I asked for pictures of their garage etc and the pics I got of course didnt show the crap lying around 🤬. On the positive I have to say they have been very good in getting back to me on any questions and so forth so on that front actually better than most … but … when I was invited to go visit the car when it was stripped down I could not have imagined a worse garage… how people can work like this is beyond me.

Place was a shambles NOTHING was clean and they were assembling a ‘new’ engine in this mess… I was stuck - car was apart and engine was out … 🙁. I would never in a million years select this shop to do my car just looking at the state of the shop. Parts lying on the floor everywhere and so dirty you could barely tell what parts were what.

Anyhow… been a nightmare but at least have the car and she runs. The bottom end I saw with new crank and looked like the machine shop they used did a decent job at least… now just to get her to run ok on cold start…. Any thoughts?

This is the part I am trying to get them to sort out - cold start running… but at this stage I am thinking of just cutting my losses and go to RCV or somewhere else…
  
Post #228827017th Apr 2022 8:32 am
View user's profile Send private message View poster's gallery Reply with quote
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4

Scott #55 wrote:
The content of your images look like URLs (web pages). Try uploading them with the Img tags? Copy the pictures to your desktop then 'Choose photos' from the button under the box where you type your text.

May well be teaching my granny to suck eggs.


Odd thats what I did … Confused
 

Last edited by stevebez on 18th Apr 2022 1:55 pm. Edited 1 time in total 
Post #228827117th Apr 2022 8:50 am
View user's profile Send private message View poster's gallery Reply with quote
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4

None of the [] functionality seems to work for me.
  
Post #228827217th Apr 2022 8:51 am
View user's profile Send private message View poster's gallery Reply with quote
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4

I am pretty sure the injector nozzles are compromised - anyone know where I can source replacement nozzles?
  
Post #228827417th Apr 2022 9:17 am
View user's profile Send private message View poster's gallery Reply with quote
popsdosh
 


Member Since: 09 Nov 2009
Location: cambs
Posts: 272

United Kingdom 2016 Discovery 4 3.0 SDV6 Graphite LE Auto Corris GreyDiscovery 4

so they did all that work and didnt get the injectors checked ? You will need to find a specialist that can work on them as they are not cheap.
The price they quoted should have got alarm bells ringing to be honest
  
Post #228827617th Apr 2022 9:33 am
View user's profile Send private message View poster's gallery Reply with quote
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4

Hmmm I expect checking injectors at this shop is taking a good look at the nozzle and using a flash light with weak batteries…. I am just trying to move on from this…

I think ill run an overflow test on injectors … see how that goes …likely in for another £1200 for a set of new ones.

Any other ideas on rough running on cold start?
  
Post #228827817th Apr 2022 9:40 am
View user's profile Send private message View poster's gallery Reply with quote
eightfoot
 


Member Since: 12 Apr 2015
Location: sunny essex
Posts: 614

United Kingdom 2005 Discovery 3 TDV6 S Auto Bonatti GreyDiscovery 3

does the d4 have an oil temp sensor in the sump like the d3 ?
 please excuse any grammer/punctuation mistakes,i'm thick,thankyou
current vehicles 2005 d3 2013 d4 
 
Post #228827917th Apr 2022 9:58 am
View user's profile Send private message View poster's gallery Reply with quote
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4

Ran the diagnostic on cold start and it doesn't have the individual injector view but fuel pressure was all over the place and once it warmed up, it settled down. I wonder if an injector coding may not help matters ... Is the code on the top of the injector or the body?
 

Last edited by stevebez on 19th Apr 2022 9:24 am. Edited 1 time in total 
Post #228833317th Apr 2022 7:22 pm
View user's profile Send private message View poster's gallery Reply with quote
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4



So this is a trace I ran with iCarsoft on cold start. Curious on MAF sensors - are there 2 or one?

The Fuel rail pressure vs Fuel Rail pressure desired looks wacko.

Fuel Volume control valve duty cycle also curious. So it all settles down somewhat after 40 seconds, although I only started recording after a minute or so.

Fuel level input - this is flat line is this the fuel tank level perhaps?
 

Last edited by stevebez on 20th Apr 2022 10:25 pm. Edited 1 time in total 
Post #228842418th Apr 2022 1:58 pm
View user's profile Send private message View poster's gallery Reply with quote
stevebez
 


Member Since: 18 Apr 2011
Location: Kent
Posts: 53

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Ipanema SandDiscovery 4

I am going to run an overflow test on the injectors and see how that looks and see if I can identify the offending injector/issue.

The garage said they replaced 2 injectors (known good used at no charge) - so perhaps they were not coded. Ill pull them all and check the coding too.

The MAF data is a bit baffling though ... bottom two lines in chart above.
  
Post #228869620th Apr 2022 10:24 pm
View user's profile Send private message View poster's gallery Reply with quote
N5Fav
 


Member Since: 28 Jan 2021
Location: LEICESTER
Posts: 127

United Kingdom 2007 Discovery 3 TDV6 XS Auto Buckingham BlueDiscovery 3

There will be a supplier near you that can test the injectors
This will involve all injectors being removed and tested on specialist high pressure rig.
Then they can run through the results with you & you can decide how many need replacing.
If you can't find anyone local, I use TT Automotive in Loughborough & have always been pleased with there service and turnaround (I have no connection with this company except having used them), but I'm sure someone can recommend somewhere in the southeast for you.
 1994 Defender 300tdi 110 commercial
2007 Disco 2.7 XS Buckingham Blue
1959 Standard 10 Coffe & Cream
1974 Vauxhall Magnum 1800 estate Olivine Starfire Green
1994 Renault 19 Cabrio
1995 Kawasaki GPz 1100 
 
Post #228876121st Apr 2022 12:56 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 2 of 2 <12
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2022 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site