Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > In Car Electronics (D3)

No indicators after trailer socket upgrade
Post Reply  Down to end
Page 1 of 1
avedelphina
 


Member Since: 14 May 2023
Location: PRG
Posts: 9

Czech Republic 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3
No indicators after trailer socket upgrade

Hi everyone,
I have one 13pin trailer socket and as there is space for two sockets, I have asked in the shop to fit the 7pin socket, so I won't have to use adapters with trailers.

I have plugged a trailer in the new socket and the indicators are not working - other lights are fine. But the problem is that they have stopped working on a car, too! I get the sound, I get the indicator lights on the dash, but no light from any. I have disconnected the trailer, but no indicators still.

Strangely, when I connect the trailer to the 13pin socket with adapter, the indicators are working, but only on the trailer, not on car!

I have also noticed that the top row of buttons where the DSC, parking sensors, hazards and locking stopped illuminating. They are all working, but no light, even on parking sensor.

What can be wrong? I will take it back to the shop, but maybe it is something easy to fix?
  
Post #23576834th Jan 2024 3:56 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 10389

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

I’d take is back to the shop.

I expect they fitted a bypass relay when one wasn’t required.
  
Post #23576964th Jan 2024 5:12 pm
View user's profile Send private message View poster's gallery Reply with quote
avedelphina
 


Member Since: 14 May 2023
Location: PRG
Posts: 9

Czech Republic 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

They said they just doubled the wires. I will take it there tomorrow, I just wonder why the indicators don't work at all.
  
Post #23577114th Jan 2024 7:17 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 10389

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Have a look under the bonnet by the battery
There is a fuse box. Look at the large fuses with windows in the top.
There are 2 with light bulb symbols. See if one has blown.

If it has I would leave it and get the shop to check things out. (Unless you think the trailer caused it )

Do you get the trailer light on the dash flash with the indicators when the trailer lights are working ?
  
Post #23577174th Jan 2024 7:51 pm
View user's profile Send private message View poster's gallery Reply with quote
avedelphina
 


Member Since: 14 May 2023
Location: PRG
Posts: 9

Czech Republic 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

Okay, new development.

The next morning, indicators work, original socket works. As soon as I connect the trailer to the new socket, flashing stops and internal indicators start pulsating quickly as if the bulb is blown.

Good news is that apparently after some cooldown period everything start working again.

So the question now is - how to correctly wire the 7pin socket from 13pin socket?
  
Post #23577455th Jan 2024 8:50 am
View user's profile Send private message View poster's gallery Reply with quote
Carl and Petra
 


Member Since: 13 Feb 2015
Location: Hautes Pyrenees
Posts: 204

France 2015 Discovery 4 3.0 TDV6 SE Auto Sumatra BlackDiscovery 4

I presume the 13 pin was working fine before any alteration?
Are you using LED bulbs on the trailer you plug in?
Am i right in thinking you got the garage to jump wires from that to a 7pin so you would have the option of both?
If so it needs them to start again or for you to strip it out and look at each wire. There is a funny jump wire in the LandRover socket they may have messed up.
The diagrams are easy enough to find on the web.
  
Post #23577715th Jan 2024 1:19 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 10389

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Pictures are always helpful. Pics of the cables inside the car on the left and ppics of the rear of the 7socket

It's difficult to imagine how incorrectly you could wire it up and cause a short. Are you sure the trailer with 7 pin plug is ok?
  
Post #23578065th Jan 2024 4:43 pm
View user's profile Send private message View poster's gallery Reply with quote
avedelphina
 


Member Since: 14 May 2023
Location: PRG
Posts: 9

Czech Republic 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

After another day or two sitting still, the indicators are working again. If I connect the trailer to the original 13pin socket, everything works, so I won't touch the new socket again until I have it checked.

In the meantime, the top row of the buttons in center console (DSC, parking sensors, hazards and locking) are not illuminated, but they work. Any idea what could cause this and to get them back to illuminate? I don't care about the buttons much, but the indicator of active parking sensors is not working either and I kind of miss that...
  
Post #23582549th Jan 2024 11:26 am
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 10389

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Are you sure the DSC button works? When you press it, do you get an orange light on the dash?
And when the yellow console Hill decent button is pressed you get a green? light on the dash?
Do the switches light up at night?

It is very bizzar what you report with your central switches.
First I would unplug them and plug them back in to ensure a good connection.
The red parking light is grounded thru pin 15 and the switch function also uses this as well as night illumination, lock buttons,

I also note that when a trailer is plugged in the rear sensors should be disabled, so if you are finding them disabled this maybe a factor

Notes to self
Fuse 66 HDC, DSC, Ill
  
Post #235878913th Jan 2024 11:51 am
View user's profile Send private message View poster's gallery Reply with quote
avedelphina
 


Member Since: 14 May 2023
Location: PRG
Posts: 9

Czech Republic 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

Yes, dash lights up and DSC off is shown on the screen. I intended to examine it a bit more as the heavy frost passed, but after a quick ride it seems that everything is working again without any problems and most importantly without me actually doing anything.

I have to admit that I hate these problems that come and go away by themselves, but on the other hand I am quite relieved that there is actually nothing wrong with the car.

Now the new socket wiring must have caused some confusion in those big electronic brains of D3 and I'm not going to press luck by using it again. So the question is how to wire it correctly? What is that funny jump wire that Carl and Petra mentioned?
  
Post #235880413th Jan 2024 1:52 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 10389

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

I expect he was referring to: When a plug is inserted the rear fog lights can be disabled via a blue wire.

It really shouldn’t be a difficult task
  
Post #235882513th Jan 2024 4:48 pm
View user's profile Send private message View poster's gallery Reply with quote
avedelphina
 


Member Since: 14 May 2023
Location: PRG
Posts: 9

Czech Republic 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

Yeah, I expected this to be pretty straightforward. I'll take it back to the garage as soon as my other car is back.
  
Post #235882813th Jan 2024 5:03 pm
View user's profile Send private message View poster's gallery Reply with quote
HairyFool
 


Member Since: 04 Jan 2023
Location: Essex
Posts: 553

United Kingdom 2016 Discovery 4 3.0 SDV6 Landmark LE Auto ZanzibarDiscovery 4

I found it quite hard to find a 13pin socket with the microswitch in to disable the rear fog lights.
 A visitor from the dark side, my other vehicle is an MG5 EV  
Post #235886113th Jan 2024 9:04 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 10389

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

Only a big deal if your towing a white or shiny caravan/trailer.
  
Post #235886613th Jan 2024 10:09 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site