Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D4)

Fuel Guage Dropping Rapidly
Post Reply  Down to end
Page 1 of 1
asj968
 


Member Since: 01 Jul 2008
Location: Kent
Posts: 74

United Kingdom 2012 Discovery 4 3.0 TDV6 HSE Auto Orkney GreyDiscovery 4
Fuel Guage Dropping Rapidly

Before I start I realise that there have been other posts on this subject however ….

My fuel guage drops rapidly when out on a journey. Switching off and switching back on again resets it to the correct level.

I have had all the connectors replaced at the tank and when that didn’t resolve the issue, I had new senders installed - so I am at £1200 with no fix yet.

The only other information I can provide is:

It would appear that it only goes down rapidly while moving. I have sat in it stationary this morning for 30 mins with the engine running and it hasn’t moved.

Also when driving I get a park brake fault come on which I thought might be the trigger but it seems that the level drops rapidly before the park brake fault comes on.

It’s a mystery to me so any thoughts gratefully accepted.
 Porsche 968 Cabrio
Discovery 4 HSE 3.0 
 
Post #233961016th Jun 2023 9:16 am
View user's profile Send private message View poster's gallery Reply with quote
NJSS
 


Member Since: 06 May 2009
Location: Catherington, Hampshire.
Posts: 10524

United Kingdom 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Waitomo GreyDiscovery 4

Sorry to hear this.

Your profile shows no Discos, but two Discos are listed in your signature. Is the problem with the Discovery 3 HSE 2.7 or the Discovery 4 HSE 3.0 ?

Good luck

NJSS
  
Post #233961216th Jun 2023 9:49 am
View user's profile Send private message View poster's gallery Reply with quote
asj968
 


Member Since: 01 Jul 2008
Location: Kent
Posts: 74

United Kingdom 2012 Discovery 4 3.0 TDV6 HSE Auto Orkney GreyDiscovery 4

Apologies - will look at that

I now only own the D4
 Porsche 968 Cabrio
Discovery 4 HSE 3.0 
 
Post #233961716th Jun 2023 10:20 am
View user's profile Send private message View poster's gallery Reply with quote
asj968
 


Member Since: 01 Jul 2008
Location: Kent
Posts: 74

United Kingdom 2012 Discovery 4 3.0 TDV6 HSE Auto Orkney GreyDiscovery 4

In the interest of closing this off, I tried to get it in at the dealership for diagnosis but there is a 7 week wait for an appointment. I spoke with a local specialist who said he could only point to a potential software issue given I had already had work done that he would do.

He gave me the number of a mobile technician who came to the house. He reset the parking brake module, also did a software update for the canbus. After doing a few resets and rebuilds in the software the park brake fault and fuel guage issue seem to have gone away.

Fingers crossed 🤞
 Porsche 968 Cabrio
Discovery 4 HSE 3.0 
 
Post #234182911th Jul 2023 2:05 pm
View user's profile Send private message View poster's gallery Reply with quote
Oswiperus
D3 Decade 


Member Since: 02 Apr 2010
Location: Chelmsford, Essex
Posts: 1592

United Kingdom 2005 Discovery 3 TDV6 SE Auto Java BlackDiscovery 3

A good result....In the end.

Thanks for posting the result, lets hope it's a permanent fix. Thumbs Up
 Stu

2016 D4 Landmark current
2022 Defender D300 SE Gone Sad
D4 2014 XS Commercial - Gone Sad
D4 2016 hse lux montalcino red - Gone
D3 2005 se java black - current
D3 2005 base manual - gone Sad
D2 1999 TD5 E white - current 
 
Post #234183011th Jul 2023 2:11 pm
View user's profile Send private message View poster's gallery Reply with quote
Maddox1965
 


Member Since: 11 May 2021
Location: Kongsvinger
Posts: 2

Norway 2010 Discovery 4 3.0 TDV6 HSE Auto Causeway GreyDiscovery 4

Hi,

I had this problem after I removed the parking brake module. First constant no fuel light. Engine stop of course. I put the module back with the connector in place. On first trip the fuel gauge dropped in a hurry. And EPB warning light was on. I put everything together , adjusted the EPB and everything was fine.
If this was fixed with reset maybe the EPB is at the limit of adjustment?
  
Post #236189413th Feb 2024 10:14 am
View user's profile Send private message View poster's gallery Reply with quote
Landylad
 


Member Since: 23 Dec 2008
Location: Aberdeenshire
Posts: 366

Scotland 2012 Discovery 4 3.0 SDV6 GS Auto Zermatt SilverDiscovery 4

Had similar problems with my fuel gauge when d*cking about with the EPB. Not sure how these two are linked, but they must have some interface. Just typical LR to be honest.
 If in doot, flat oot!!  
Post #236286225th Feb 2024 11:18 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site