Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Maintenance & Mods (D4)

Fault P2BAE-00(2F)
Post Reply  Down to end
Page 1 of 2 12>
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 326

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3
Fault P2BAE-00(2F)

Driving on the motorway today I get a message stating poor quality ad-blue, but it’s the same as it’s had in for weeks, not been topped up or anything.
Then message changed to NOx monitoring system fault.
I get home and screen displays 540miles until the car won’t start.
I plug iid in and get




I know it’s related to the add blue system but has anyone seen/remedied it.
  
Post #212993320th Mar 2020 7:02 pm
View user's profile Send private message View poster's gallery Reply with quote
Fifth Horseman
 


Member Since: 23 Oct 2012
Location: Lanarkshire
Posts: 211

United Kingdom 2013 Discovery 4 3.0 SDV6 XS Auto Ipanema SandDiscovery 4

The incorrect quality DEF fluid message is generated when the sensors either side of the NOx catalyst do not detect the correct reduction in NOx level. That along with the second error message suggests the system thinks it is not delivering enough Ad-Blue fluid.

As a first check, it would be worth getting underneath the vehicle and checking the wiring to the sensors and DEF fluid tank. Also check for any fluid leaks between the tank (above the spare wheel) and fluid injector on the exhaust system (IIRC, just before the first box on the exhaust after the left and right sides join behind the engine).

After that its a case of testing that the catalyst is not contaminated and the system is delivering the correct amount of fluid - the latter requires the use of a diagnostic system, I don't know it the IIDTool can do this.

Can't help much further with the specifics of the D4 system, the knowledge I have is with the FFRR.
  
Post #213009421st Mar 2020 10:22 am
View user's profile Send private message View poster's gallery Reply with quote
Hardware
 


Member Since: 28 Jun 2016
Location: Hiding under the M60
Posts: 6710

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

and your profile needs updating too !!
  
Post #213009721st Mar 2020 10:34 am
View user's profile Send private message View poster's gallery Reply with quote
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 326

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

Cheers for the advice, I’ll have a look tomorrow, the D4 is still under the sellers warranty but there 150 miles from me so if it’s something simple I’ll have a look.
As for profile updating, I still have the D3, and sort of regretting buying the D4 as things stand.
  
Post #213010421st Mar 2020 10:47 am
View user's profile Send private message View poster's gallery Reply with quote
Hardware
 


Member Since: 28 Jun 2016
Location: Hiding under the M60
Posts: 6710

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

suspect that will change rapidly once the ad-blu thing is fixed
  
Post #213011021st Mar 2020 11:03 am
View user's profile Send private message View poster's gallery Reply with quote
Hardware
 


Member Since: 28 Jun 2016
Location: Hiding under the M60
Posts: 6710

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

Ok ... i have no idea how pipes or wiring run for the ad-blu BUT is it possible you've interrupted them fitting the winch and mount?
 .


Dean
====================================
2011 D4 XS - OBD port protection, RLD spare wheel protector, All LED interiors lights, Timed Climate enabled, iiD tool paired.
2011 D4 Landmark - Stolen from same dealer before I paid for it
2011 D4 GS - Stolen whilst at dealer Sad ... All LED interiors lights, DRLs, Spare Wheel protector.
1996 300Tdi - Eaten by tin worms 
 
Post #213016321st Mar 2020 2:47 pm
View user's profile Send private message View poster's gallery Reply with quote
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 326

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

No chance of disturbing ad blue system with front mounted winch.
I’ve been under the car and found a previous repair to the wiring but the repair has continuity so I think that’s ok.

  
Post #213020121st Mar 2020 4:20 pm
View user's profile Send private message View poster's gallery Reply with quote
M3bobby
 


Member Since: 21 May 2018
Location: Sleaford, LINCS.
Posts: 677

United Kingdom 

Do you know why you have a double rear light failure? It’s odd that they have appeared at the same time as the adblue fault. If you don’t know the reason for those failures I would double check that wiring. You may have continuity but it doesn’t mean you don’t have a short to the rear lights or ground. I don’t know why those circuits would be together but it is a little odd.
 012MY RRS 5.0 Supercharged Autobiography (Current)
Mods:
TPMS (Complete but got an issue)
Genuine LR DRLs (Complete)
Remote Boot close from key fob (Complete)
2016 Discovery 4 Mirrors AKA RRS2 (Complete)
2014 L405 Surround Camera retro fit (Now 2016 L319)
2013 RRS Dual View Screen fit (Complete)
2016 LR4 RSE (Complete)
2014 LR4 Homelink (Complete)
2016 FFRR Electrochromatic Wing Mirror Glass (Complete) 
 
Post #213021921st Mar 2020 6:06 pm
View user's profile Send private message View poster's gallery Reply with quote
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 326

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

The strange thing is that I don’t have any light failure, but I thought it may be related
  
Post #213022021st Mar 2020 6:26 pm
View user's profile Send private message View poster's gallery Reply with quote
M3bobby
 


Member Since: 21 May 2018
Location: Sleaford, LINCS.
Posts: 677

United Kingdom 

You could try opening up that repair and then clearing the fault codes to see if they come back. I would definitely be suspect of that repair. You could also continue to check other cables around there to, especially connectors as LR contractors have been known to forget to fit the seals on the wires.
 012MY RRS 5.0 Supercharged Autobiography (Current)
Mods:
TPMS (Complete but got an issue)
Genuine LR DRLs (Complete)
Remote Boot close from key fob (Complete)
2016 Discovery 4 Mirrors AKA RRS2 (Complete)
2014 L405 Surround Camera retro fit (Now 2016 L319)
2013 RRS Dual View Screen fit (Complete)
2016 LR4 RSE (Complete)
2014 LR4 Homelink (Complete)
2016 FFRR Electrochromatic Wing Mirror Glass (Complete) 
 
Post #213023021st Mar 2020 6:58 pm
View user's profile Send private message View poster's gallery Reply with quote
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 326

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

I opened the repair it’s all good with proper connection and resin bonded.
I opened connections and sprayed with contact cleaner, re assembled but faults still there.
I’m at the limit of my auto electrical knowledge now.
  
Post #213023121st Mar 2020 7:03 pm
View user's profile Send private message View poster's gallery Reply with quote
M3bobby
 


Member Since: 21 May 2018
Location: Sleaford, LINCS.
Posts: 677

United Kingdom 

Just a thought but is it a repair or is it a new NOx sensor that’s been soldered in to the harness? Could it be a cheap sensor that’s failed? One that has a pre-wired loom that is spliced into the LR Loom? Can you see any details on the sensor it’s self?
 012MY RRS 5.0 Supercharged Autobiography (Current)
Mods:
TPMS (Complete but got an issue)
Genuine LR DRLs (Complete)
Remote Boot close from key fob (Complete)
2016 Discovery 4 Mirrors AKA RRS2 (Complete)
2014 L405 Surround Camera retro fit (Now 2016 L319)
2013 RRS Dual View Screen fit (Complete)
2016 LR4 RSE (Complete)
2014 LR4 Homelink (Complete)
2016 FFRR Electrochromatic Wing Mirror Glass (Complete) 
 
Post #213024421st Mar 2020 7:48 pm
View user's profile Send private message View poster's gallery Reply with quote
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 326

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

I’ll look tomorrow
  
Post #213024921st Mar 2020 8:01 pm
View user's profile Send private message View poster's gallery Reply with quote
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 326

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

Update. It’s been in at a garage today with a fault of probable in tank ad blue pump failure.
It’s at a better equipped Land Rover only garage now, with dealer level diagnostics to try to run the ad blue system independently of the car. If it is the pump it’s on a 3 month back order at Land Rover
  
Post #213093823rd Mar 2020 7:55 pm
View user's profile Send private message View poster's gallery Reply with quote
johnlad
 


Member Since: 02 Dec 2016
Location: blackpool
Posts: 326

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Buckingham BlueDiscovery 3

Another update.
It’s had a software update and all faults are clear for now, but if it returns then a NOX sensor is required. £78 for diagnostic and updates.
  
Post #213127424th Mar 2020 1:53 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 1 of 2 12>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2020 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site