Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > Faults & Fixes (D4)

D4 touchscreen goes white - radio still works
Post Reply  Down to end
Page 1 of 1
Davethegeo
 


Member Since: 01 Oct 2015
Location: Edinburgh
Posts: 888

Scotland 2014 Discovery 4 3.0 SDV6 HSE Auto Corris GreyDiscovery 4
D4 touchscreen goes white - radio still works

I started up the car this morning after it had sat for a few days. Was chilly but nothing terrible. The car started on the button, but the centre touchscreen was totally white. The radio worked, and the virtual buttons on the screen - although invisible - worked fine. in fact I could turn the screen off by tapping the bottom left of the screen a few times and the screen went black. Stopped and started the engine, but the screen was still white.
I went back to the car a few hours later (it was in for a successful MOT) and the screen was working fine.

Has anyone seen this? Couldn't find it in the forum anywhere. is there a fix or is it just one of things that we learn to live with and will probably never happen again.
 D1 300Tdi - gone
D2 Td5 ES (Alive remapped...mmm) - sadly gone
D4 2012 SDV6 XS - Stolen
D4 2014 SDV6 HSE - Shiny


 
 
Post #236296926th Feb 2024 6:24 pm
View user's profile Send private message View poster's gallery Reply with quote
nigethecat
 


Member Since: 11 Sep 2016
Location: Marnoch
Posts: 4161

Ukraine 2016 Discovery 4 3.0 SDV6 Commercial XS Auto Corris GreyDiscovery 4

I've not heard of that but did find this link...

https://www.disco3.co.uk/forum/nav-screen-...ite+screen

Not quite the same issue but potentially related... no final solution though Crying or Very sad
 I want to see the sweets before I get into your windowless van... I'm not stupid!

Corris Grey D4 Commercial SE 2016
Zermatt Sliver 2007 D3 SE manual (gone)
Indus Silver D4 HSE 2015 (gone)
Bonatti Grey D3 HSE 2006 (gone)
White D3 S (LHD) 2007 (gone)
Firenze Red D4 HSE 2014 (gone)
Black RRS 3.6TDV8 2008 (gone)
Rusty Green Defender 110 1997 (gone)
Black FL2 HSE 2013 (gone) 
 
Post #236297326th Feb 2024 7:22 pm
View user's profile Send private message View poster's gallery Reply with quote
Gilgamesh
 


Member Since: 01 Feb 2024
Location: Beckenham
Posts: 15

England 

It could very well be a software glitch.
  
Post #236317229th Feb 2024 12:36 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site