Advertise on DISCO3.CO.UK
Forum · Gallery · Wiki · Shop · Sponsors
DISCO3.CO.UK > General (D4)

Assistance required - kind of urgent :D
Post Reply  Down to end
Page 1 of 1
Nickdisco
 


Member Since: 24 Aug 2017
Location: North West
Posts: 84

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Indus SilverDiscovery 4
Assistance required - kind of urgent :D

2010 D4 - 3.0tdv6 with ZF6SP RHD

235+k miles
In good condition as it were.

Currently 3 weeks in to a 6 month trip into Europe. Currently located in Sunny Beach, Bulgaria.

Gearbox fault displayed on cluster.

Stick selector moves freely between PRND, Dash takes a few seconds to acknowledge what gear its supposed to be in, along with shunt from gearbox when selecting between them.

Fault can disappear upon vehicle sleep or IID code clear.

Fault codes
U0402-00 - invalid data from TCM on multiple modules
P0700- Transmission request for MIL
P0915-01 - Gearshift position circuit range electrical failure

Doesn't display when driving, seemingly fault only appears when switching between PRND etc.

Happens in Low Range too.

As I'm out in Bulgaria, I do have a good selection of tools etc I can use, where should I be looking or looking at?

The TCM up by the brake master cylinder or the wiring connections on or around the transfer box and gearbox?

Or should I start heading back to UK with expectation of removing gearbox and changing it all.
Had new TC and fluid 70k ago, other than this fault, theres no other issues

Click image to enlarge

Click image to enlarge
 Silver MY10 D4
Prospeed Rack / Ladder and Accessories
Shire Sliders
GG AT3
Genuine LR RAI
The list goes on... 
 
Post #23497316th Oct 2023 11:15 am
View user's profile Send private message View poster's gallery Reply with quote
grzesiul
 


Member Since: 11 May 2008
Location: UK
Posts: 6294

Poland 2016 Discovery 4 3.0 SDV6 SE Auto Loire BlueDiscovery 4

have you checked your main battery state ?

i would start with that.

G
  
Post #23497326th Oct 2023 11:29 am
View user's profile Send private message View poster's gallery Reply with quote
grzesiul
 


Member Since: 11 May 2008
Location: UK
Posts: 6294

Poland 2016 Discovery 4 3.0 SDV6 SE Auto Loire BlueDiscovery 4

this might be of help I hope: https://www.rangerovers.net/threads/2012-r...es.340763/
  
Post #23497336th Oct 2023 11:31 am
View user's profile Send private message View poster's gallery Reply with quote
grzesiul
 


Member Since: 11 May 2008
Location: UK
Posts: 6294

Poland 2016 Discovery 4 3.0 SDV6 SE Auto Loire BlueDiscovery 4

brake switch playing up with ECUs if faulty of failing?

G
  
Post #23497346th Oct 2023 11:33 am
View user's profile Send private message View poster's gallery Reply with quote
darrind
 


Member Since: 04 Jul 2008
Location: In A World of My Own!
Posts: 2863

England 2013 Discovery 4 3.0 SDV6 HSE Auto Santorini BlackDiscovery 4

Gearbox linkage corroded and starting to seize up would be my guess, or the linkage has seized and been repaired but not quite located in the correct position. WD 40 over the selector linkage from underneath might help get moving again if it is, however you will probably have to remove the gearbox under-shield to reach it.
 Must stop buying shiny toys....  
Post #23497366th Oct 2023 11:51 am
View user's profile Send private message View poster's gallery Reply with quote
Nickdisco
 


Member Since: 24 Aug 2017
Location: North West
Posts: 84

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Indus SilverDiscovery 4

grzesiul wrote:
have you checked your main battery state ?

i would start with that.

G


Main battery is good, 1 year old.

I've got Tmax split charge linked to Yellowtop battery so can monitor charge level. No prior issues till this, car is daily used
 Silver MY10 D4
Prospeed Rack / Ladder and Accessories
Shire Sliders
GG AT3
Genuine LR RAI
The list goes on... 
 
Post #23497826th Oct 2023 4:17 pm
View user's profile Send private message View poster's gallery Reply with quote
Nickdisco
 


Member Since: 24 Aug 2017
Location: North West
Posts: 84

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Indus SilverDiscovery 4

darrind wrote:
Gearbox linkage corroded and starting to seize up would be my guess, or the linkage has seized and been repaired but not quite located in the correct position. WD 40 over the selector linkage from underneath might help get moving again if it is, however you will probably have to remove the gearbox under-shield to reach it.


I'll double check in the morning but it doesn't appear to be corroded, gearbox selector moves easily enough between PRND. But its worth a shot.

The post 2 up from the RR forum would likely indicate TCM failure/Mechatronic failure in the gearbox. That's where I'm thinking now
 Silver MY10 D4
Prospeed Rack / Ladder and Accessories
Shire Sliders
GG AT3
Genuine LR RAI
The list goes on... 
 
Post #23497836th Oct 2023 4:22 pm
View user's profile Send private message View poster's gallery Reply with quote
Trailered Movements
 


Member Since: 16 Jan 2020
Location: East/West Sussex Coast Borders
Posts: 1200

United Kingdom 2011 Discovery 4 3.0 SDV6 Commercial Auto Sumatra BlackDiscovery 4

Not saying it is the same as my ex issue, but;

https://www.disco4.com/forum/gearbox-issue...00063.html



Dave
 2011 Discovery 4 Commercial SDV6 (Gone)
2010 RRS TDV8 (Gone)
1980 OBLIC 4.0ltr Range Rover (went a long time ago) 
 
Post #23497886th Oct 2023 4:46 pm
View user's profile Send private message View poster's gallery Reply with quote
Nickdisco
 


Member Since: 24 Aug 2017
Location: North West
Posts: 84

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Indus SilverDiscovery 4

I have read your thread and it does seem similar.

Were you having issues doing Hi to Low range changes too? Did you ever have problems whilst driving before changing the parts?

As I'm out in Bulgaria I'm wondering how far I'll get and if it'll fault out whilst driving or if it'll just fault whilst shifting between PRND
 Silver MY10 D4
Prospeed Rack / Ladder and Accessories
Shire Sliders
GG AT3
Genuine LR RAI
The list goes on... 
 
Post #23498006th Oct 2023 8:30 pm
View user's profile Send private message View poster's gallery Reply with quote
Trailered Movements
 


Member Since: 16 Jan 2020
Location: East/West Sussex Coast Borders
Posts: 1200

United Kingdom 2011 Discovery 4 3.0 SDV6 Commercial Auto Sumatra BlackDiscovery 4

Sorry for the late reply.

No issues from High to Low, or whilst motoring, the only other sympton was a marked shunt going into any forward position or reverse.

We did however manage to prove it did only occur when the gearbox had some heat in it, which ultimately led us to our diagnosis.

If your problems occur when cold as well, then a long journey might not be a good idea.


Dave
 2011 Discovery 4 Commercial SDV6 (Gone)
2010 RRS TDV8 (Gone)
1980 OBLIC 4.0ltr Range Rover (went a long time ago) 
 
Post #23498087th Oct 2023 7:43 am
View user's profile Send private message View poster's gallery Reply with quote
Nickdisco
 


Member Since: 24 Aug 2017
Location: North West
Posts: 84

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Indus SilverDiscovery 4

Perfect thank you.

Did you end up repairing it yourself or putting it in somewhere?

I think its the same fault by your diagnosis
 Silver MY10 D4
Prospeed Rack / Ladder and Accessories
Shire Sliders
GG AT3
Genuine LR RAI
The list goes on... 
 
Post #23498157th Oct 2023 10:01 am
View user's profile Send private message View poster's gallery Reply with quote
Trailered Movements
 


Member Since: 16 Jan 2020
Location: East/West Sussex Coast Borders
Posts: 1200

United Kingdom 2011 Discovery 4 3.0 SDV6 Commercial Auto Sumatra BlackDiscovery 4

I got my indie to change the unit, it really needs to be up in the air, it's a pain just getting the sump off.

Got my megatronic unit from Frongoch Range Rovers, search the net for them, they have an ebay shop and are very knowledgeable and extremely helpful.


Dave
 2011 Discovery 4 Commercial SDV6 (Gone)
2010 RRS TDV8 (Gone)
1980 OBLIC 4.0ltr Range Rover (went a long time ago) 
 
Post #23498207th Oct 2023 11:42 am
View user's profile Send private message View poster's gallery Reply with quote
Nickdisco
 


Member Since: 24 Aug 2017
Location: North West
Posts: 84

United Kingdom 2010 Discovery 4 3.0 TDV6 HSE Auto Indus SilverDiscovery 4

I've messaged them on eBay, will see what comes back.

At the moment I'm waiting on assistance an quotes from a few places out here.

One in Bucharest, Romania.

2 in Bulgaria.

Failing that, it'll be a case of getting the mechatronic and TCM possibly posted out or flown over, and do it myself out here.

Time to read up on the ins and outs
 Silver MY10 D4
Prospeed Rack / Ladder and Accessories
Shire Sliders
GG AT3
Genuine LR RAI
The list goes on... 
 
Post #23499689th Oct 2023 7:00 pm
View user's profile Send private message View poster's gallery Reply with quote
bensla
 


Member Since: 02 May 2023
Location: Trowbridge
Posts: 141

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

How did you get on?
  
Post #23553608th Dec 2023 10:45 pm
View user's profile Send private message View poster's gallery Reply with quote
NJSS
 


Member Since: 06 May 2009
Location: Catherington, Hampshire.
Posts: 10592

United Kingdom 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Waitomo GreyDiscovery 4

The post above, 9th October, is the most recent post from Nick.

Hopefully all's well Thumbs Up
  
Post #23553779th Dec 2023 9:51 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO3.CO.UK Copyright © 2004-2024 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO3.CO.UK is independent and not affiliated to Land Rover.
Switch to Mobile Site